[caasp-beta] RC2 issues.

Ns, Rushi rushi.ns at sap.com
Mon Jul 17 13:51:10 MDT 2017


Here are my updates to the RC2 build.

1)    Adding new nodes to existing cluster works –

This is really cool feature and worked  but I see one problem.

Kubectl config file doesn’t get update to find the new nodes, “kubectl get nodes” still shows old nodes entries  but not the new one recently added after the cluster build.

i cannot download  “KUEBCONFIG” file from dashboard again after adding new nodes to the cluster which was enabled  before and I was abel to download before the first cluster time but after adding new node I can’t as this is “gray out”

2)    No Storage Class is available  ?

Kubectl get sc  - output shows nothing

3)    No ingress is available

I will check more but right now the above is not working.

Best Regards,


From: <caasp-beta-bounces at lists.suse.com> on behalf of SUSE Beta Program <beta-programs at lists.suse.com>
Reply-To: SUSE Beta Program <beta-programs at lists.suse.com>
Date: Friday, July 14, 2017 at 2:46 AM
To: "caasp-beta at lists.suse.com" <caasp-beta at lists.suse.com>
Subject: [caasp-beta] [ANNOUNCE] SUSE Container as a Service Platform 1.0 RC 2 is available!

Having trouble viewing this email? Please check the plain text version of it with your mailer.



We are happy to announce SUSE Container as a Service Platform 1.0 Release Candidate 2!
Download ›<https://www.suse.com/betaprogram/caasp-beta/#download>

As usual, hundreds of fixes and updates have been made and you can check them out in our Full Changelog<https://www.suse.com/betaprogram/wp-content/uploads/2017/07/SUSE-CaaS-Platform-1.0-ChangeLog-RC1-RC2.txt>.

Notable Changes since RC 1:


  *   Adding Nodes to a deployed cluster:
With this release of RC2 we have implemented adding new nodes to an already deployed cluster.
  *   Removing nodes prior bootstrapping:
We changed the UI of bootstrapping the cluster. you may now select single nodes in the UI which you would like to add to your cluster before bootstrapping. For your convenience we added a 'Accept all Nodes' button ;-)
  *   Security:
CaaSP has gone through a security audit and a significant amount of security improvements have been implemented in the past weeks. What you will experience is that Velum is now available at https.


  *   A btrfs deadlock was solved by a kernel update that made CaaSP freeze after rebooting. (bsc#1041296)
  *   Scalability and stability of the cluster has been improved perceptibly.

Upgraded Packages:

  *   docker.x86_64: 1.12.6-3.1 => 1.12.6-5.3
  *   etcd.x86_64: 3.1.0-2.15 => 3.1.0-2.28
  *   flannel.x86_64: 0.7.1-1.17 => 0.7.1-1.30
  *   kernel-default.x86_64: 4.4.59-92.17.3 => 4.4.74-1.5
  *   kubernetes-client.x86_64: 1.5.3-3.1 => 1.5.3-3.15
  *   kubernetes-common.x86_64: 1.5.3-3.1 => 1.5.3-3.15
  *   kubernetes-kubelet.x86_64: 1.5.3-3.1 => 1.5.3-3.15
  *   kubernetes-master.x86_64: 1.5.3-3.1 => 1.5.3-3.15
  *   kubernetes-node.x86_64: 1.5.3-3.1 => 1.5.3-3.15
  *   systemd.x86_64: 228-142.1 => 228-149.3

Release plan ›<https://www.suse.com/betaprogram/caasp-beta/#releases>

Release Notes ›<https://www.suse.com/betaprogram/caasp-beta/#releasenotes>

Documentation ›<https://www.suse.com/betaprogram/caasp-beta/#documentation>

Have fun beta testing!

Your SUSE Linux Enterprise Team

Please refer to our dedicated SUSE CaaSP Beta Program<https://www.suse.com/betaprogram/caasp-beta/> webpage for any general information. However, do not hesitate to contact us at beta-programs at lists.suse.com<mailto:beta-programs at lists.suse.com> if you have any questions.

You received this email because you're signed up to get updates from us. Click here to unsubscribe.<mailto:beta-programs at lists.suse.com?subject=Unsubscribe%20from%20SUSE%20CaaSP%20Beta&body=Unsubscribe%20Unsubscribe%20from%20SUSE%20CaaSP%20Beta>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.suse.com/pipermail/caasp-beta/attachments/20170717/4e098175/attachment.htm>

More information about the caasp-beta mailing list