[sle-beta] Beta 3, no Gnome

Joe Doupnik jrd at netlab1.net
Wed Nov 29 07:51:03 MST 2017

     I seem to be caught in a snare on beta 3 Server. The problem is 
obtaining Gnome.
     Last week I discussed SSL version problems in beta 3 and the test 
machine has Gnome running fine. This week I am diagnosing the SSL aspect 
and building now shows no graphical login choice. That is, during 
installation a Systems Role screen appears. It now shows Text Mode, 
Minimal, KVM, ZEN, but nothing else. There is no Gnome in the YaST 
software menu either, the Graphical Environments section shows only 
Fonts and X Window System . Try as I might, nothing improves this situation.
     Installation is as a regular VMware ESXi v6 virtual machine. I have 
tried all the video mode selection values on the boot screen, including 
"default" and telling the boot kernel "nomodeset" and the situation does 
not change. Normally I select 1024x768 as that has worked fine on all 
the many SUSE based virtual machines here for years.
     I have tried not choosing repositories, and the Roles screen shows 
only Minimal. If I disconnect the network and start an install then 
again the Roles screen shows only Miminal. This reduction in 
capabilities is definitely not good. The installation media alone ought 
to have what it takes to build a regular GUI based server, no frills, 
and apparently in beta 3 that is not the case (which is a strange 
     At installation time I also see the system try to reach SUSE and 
update the installer, without my permission. That is also an unwise 
step, breaking confidence in the DVD material to do the installation job 
and adding unknown things at the very start. I have no trust in such 
remote fetch actions. I suggest either skipping that update step or 
requiring the user's permission to do it.
     Don't ask why I got away with this last week. I must have been very 
bad over the weekend to deserve this treatment.
     Joe D.

More information about the sle-beta mailing list