[Deepsea-users] filestore to bluestore migration

Thomas Sundell thsundel at gmail.com
Mon Dec 11 08:24:00 MST 2017

Hi again,

On Mon, Dec 11, 2017 at 2:19 PM, Eric Jackson <ejackson at suse.com> wrote:
>> :) 5 of them got migrated but then I hit an error:
>> "Module function osd.redeploy threw an exception. Exception: Device
>> /dev/sda is not defined in pillar"
> I expect the device is defined in the local grains, but not in the pillar.

Exactly, when I ran proposal.populate to create a new profile it seems
to not have picked up the first disk of each node and looking in
/etc/salt/grains on the storage nodes the disk is defined there.

>> So I took a look in the osd*.yml and noticed the first disk of every
>> node was missing, so I manually edited the files and added the missing
>> disk of each node and reran the above steps but still I'm hitting the
>> same error.
>> And now after I edited the files and run osd.report it states "No OSD
>> configured for" the disks I added manually.
> So, these first disks never had an OSD?  That would seem to contradict the
> grains above.  Were these deleted manually?

I found the cause why it stated "No OSD configured for" the disks I
manually added to the profile, there was a typo in the
/dev/disk/by-id.... line in the yml, had a capital O instead of a
zero, uups ;)

Migration to bluestore is now done but for some reason one OSD is
missing, have to investigate.

Thank you once again Eric!


More information about the Deepsea-users mailing list