[sle-beta] Anyone seeing issues with starting gnome-terminal?

Mike Marion mmarion at qualcomm.com
Tue Nov 21 15:26:36 MST 2017

On Tue, Nov 21, 2017 at 05:24:15PM +0100, Frederic Crozat wrote:

> I think it related to the fact GNOME Terminal (and many GNOME
> applications) are designed to connect to a D-Bus session, which isn't
> running if you are using ssh / NX or might be terminated at some point.

It should try to start up dbus though, and it works/worked on SLE <15.

> And to be honest, I fail to see the value of running xterm / gnome-
> terminal over SSH: you'll get high latency. It might be better to run
> your commands directly over ssh or use full desktop remote desktop
> session, like VNC or RDP (which will better handle compression).

Oh I know, it's just that it's something that has always worked before.
I was actually trying to simply run it inside of an NX session initally
as well.  

LOL.. I just tried something.. I started a vncserver on the SLE15 host,
connected... gnome works.  NOW I can start another gnome-terminal via
ssh or NX as well.  I've seen a similar odd thing on 12.3 as well where
if I start a remote NX session first, I can't login to gnome on the
console without killing the NX session first.

I think I'm getting hit by gnome-dev "I never use it that way" decisions.

I tested by rebooting the VM:
$ gnome-terminal
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

$ vncserver 
New 'susetest-kvm:1 ($ME)' desktop is susetest-kvm:1

Starting applications specified in /usr2/$ME/.vnc/xstartup
Log file is /usr2/$ME/.vnc/susetest-kvm:1.log

Connected and couldn't open gnome-terminal via gnome buttons this time, but 
starting xterm and running it inside the vnc session worked, now, via ssh 
gnome-terminal works again.

Mike Marion-Unix SysAdmin/Sr. Staff IT Engineer-http://www.qualcomm.com

More information about the sle-beta mailing list