[sle-beta] Anyone seeing issues with starting gnome-terminal?

Frederic Crozat fcrozat at suse.com
Wed Nov 22 01:52:01 MST 2017

Le mardi 21 novembre 2017 à 22:26 +0000, Mike Marion a écrit :
> On Tue, Nov 21, 2017 at 05:24:15PM +0100, Frederic Crozat wrote:
> > 
> > I think it related to the fact GNOME Terminal (and many GNOME
> > applications) are designed to connect to a D-Bus session, which
> > isn't
> > running if you are using ssh / NX or might be terminated at some
> > point.
> It should try to start up dbus though, and it works/worked on SLE
> <15.

gnome-terminal has changed since SLE12 to use a "factory" process to
handle the various terminal creation, this is probably the reason you
have this issue.
> > 
> > And to be honest, I fail to see the value of running xterm / gnome-
> > terminal over SSH: you'll get high latency. It might be better to
> > run
> > your commands directly over ssh or use full desktop remote desktop
> > session, like VNC or RDP (which will better handle compression).
> Oh I know, it's just that it's something that has always worked
> before.
> I was actually trying to simply run it inside of an NX session
> initally
> as well.  
> LOL.. I just tried something.. I started a vncserver on the SLE15
> host,
> connected... gnome works.  NOW I can start another gnome-terminal via
> ssh or NX as well.  I've seen a similar odd thing on 12.3 as well
> where
> if I start a remote NX session first, I can't login to gnome on the
> console without killing the NX session first.

This is expected: only one graphical session for a single user is
allowed at the same time.

This is why are shipping a VNC multiplexer to handle this kind of issue

Frederic Crozat
Enterprise Desktop Release Manager

More information about the sle-beta mailing list