[sle-beta] Issues with Migration SLES12 SP-3 to SP-4 Beta1

Waite, Dick (External) Dick.Waite at softwareag.com
Sun Jul 29 09:58:12 MDT 2018

Evening Oliver,

The two text files were run on SP-3 just to check there was an issue there. Most of my test virtual machines are clones of real working machines, being used by QE, service and dev. staff, they are not idle test machines. I did use a clean machine for the first test, which ran grand. I do try to use good old work environments to make sure they too will migrate. I did have to remove the NCC from /etc/zypp/credentials.d as one has too for SLES15. I also have to clean up /etc/tmpfiles.d/tmp.conf...

Some of these machines started life in SLES10 so the have a good history... Like are our applications Adabas, now over 40 years old, some customers will not "install new", so we do try to Migrate / Update as much as possible..

I'll run some more tomorrow, but I think this is looking good so far

Just an update on Bugzilla, I did try again while writing this and I'm getting the same issues as this morning. I did create a few bugs with SLES12 SP-3 and SLES15 SP-0 but:
"Sorry, either the product Beta SUSE Linux Enterprise Server 12 SP4 does not exist or you aren't authorized to enter a bug into it" has a red background.... Maybe a task for someone on Monday.

Many thanks for your update.

From: sle-beta-bounces at lists.suse.com [sle-beta-bounces at lists.suse.com] on behalf of Oliver Kurz [okurz at suse.de]
Sent: 29 July 2018 15:05
To: sle-beta at lists.suse.com
Subject: Re: [sle-beta] Issues with Migration SLES12 SP-3 to SP-4 Beta1

On Sunday, 29 July 2018 14:03:29 CEST Waite, Dick (External) wrote:
> Grand Afternoon,
> I'm told these files are not needed, so I have removed them and the
> Migration ran Okay.

> I have a VMware Snapshot at the start so I can use that for Beta2 and see
> what that brings. So two Migrations both now running grand.

> __R
> ________________________________
> From: Waite, Dick (External)
> Sent: 29 July 2018 10:29
> To: sle-beta at lists.suse.com
> Subject: RE: Issues with Migration SLES12 SP-3 to SP-4 Beta1
> Grand Morning,
> I ran a SLES12 SP4 Beta1 Migration on a simple machine and it completed with
> no issues.

> I ran a SLES12 SP4 Beta1 Migration on a more complex machine and it gave
> issues as shown in the attached files.
> As the files looked like they were
> needed I stopped.
> I did try to create a Bug report but was told I was not allowed...

Well, on a clean system using only the officially supported repositories the
error as you attached should not happen. What approach did you select for
migration? The attached command outputs you provided show "SLE12 SP3" in the
names not "SLE12 SP4" so at does not exactly look a clean state.

sle-beta mailing list
sle-beta at lists.suse.com

Software AG – Sitz/Registered office: Uhlandstraße 12, 64297 Darmstadt, Germany – Registergericht/Commercial register: Darmstadt HRB 1562 - Vorstand/Management Board: Karl-Heinz Streibich (Vorsitzender/Chairman), Eric Duffaut, Dr. Wolfram Jost, Arnd Zinnhardt, Dr. Stefan Sigg; - Aufsichtsratsvorsitzender/Chairman of the Supervisory Board: Dr. Andreas Bereczky - http://www.softwareag.com

More information about the sle-beta mailing list